๋ณธ๋ฌธ์œผ๋กœ ์ด๋™

๊ธฐํšŒ์ฃผ์˜์  TLS

์œ„ํ‚ค๋ฐฑ๊ณผ, ์šฐ๋ฆฌ ๋ชจ๋‘์˜ ๋ฐฑ๊ณผ์‚ฌ์ „.
(STARTTLS์—์„œ ๋„˜์–ด์˜ด)

๊ธฐํšŒ์ฃผ์˜์  TLS(Opportunistic TLS)๋Š” ์•”ํ˜ธํ™”๋œ ํ†ต์‹ ์„ ์œ„ํ•ด ๋ณ„๋„์˜ ํฌํŠธ๋ฅผ ์‚ฌ์šฉํ•˜๋Š” ๋Œ€์‹  ์ผ๋ฐ˜ ํ…์ŠคํŠธ ์—ฐ๊ฒฐ์„ ์•”ํ˜ธํ™”๋œ(TLS ๋˜๋Š” SSL) ์—ฐ๊ฒฐ๋กœ ์—…๊ทธ๋ ˆ์ด๋“œํ•˜๋Š” ๋ฐฉ๋ฒ•์„ ์ œ๊ณตํ•˜๋Š” ํ”Œ๋ ˆ์ธ ํ…์ŠคํŠธ ํ†ต์‹  ํ”„๋กœํ† ์ฝœ์˜ ํ™•์žฅ์„ ๋‚˜ํƒ€๋‚ธ๋‹ค. ์—ฌ๋Ÿฌ ํ”„๋กœํ† ์ฝœ์—์„œ๋Š” ์ด ๋ชฉ์ ์œผ๋กœ "STARTTLS"๋ผ๋Š” ๋ช…๋ น์„ ์‚ฌ์šฉํ•œ๋‹ค. ์ด๋Š” ๊ธฐํšŒ์ฃผ์˜์  ์•”ํ˜ธํ™”์˜ ํ•œ ํ˜•ํƒœ์ด๋ฉฐ ์ฃผ๋กœ ์ˆ˜๋™ ๋ชจ๋‹ˆํ„ฐ๋ง์— ๋Œ€ํ•œ ๋Œ€์‘์ฑ…์œผ๋กœ ์‚ฌ์šฉ๋œ๋‹ค.

IMAP ๋ฐ POP3์— ๋Œ€ํ•œ STARTTLS ๋ช…๋ น์€ RFC 2595, SMTP์— ๋Œ€ํ•ด RFC 3207, XMPP์— ๋Œ€ํ•ด RFC 6120, NNTP์— ๋Œ€ํ•ด RFC 4642์— ์ •์˜๋˜์–ด ์žˆ๋‹ค. IRC์˜ ๊ฒฝ์šฐ IRCv3 ์ž‘์—… ๊ทธ๋ฃน์—์„œ STARTTLS ํ™•์žฅ์„ ์ •์˜ํ–ˆ์ง€๋งŒ ๋‚˜์ค‘์— ๊ตฌ์‹์ด ๋˜์—ˆ๋‹ค.[1] FTP๋Š” RFC 4217์— ์ •์˜๋œ "AUTH TLS" ๋ช…๋ น์„ ์‚ฌ์šฉํ•˜๊ณ , LDAP๋Š” RFC 2830์— ํ”„๋กœํ† ์ฝœ ํ™•์žฅ OID๋ฅผ ์ •์˜ํ•œ๋‹ค. HTTP๋Š” ์—…๊ทธ๋ ˆ์ด๋“œ ํ—ค๋”๋ฅผ ์‚ฌ์šฉํ•œ๋‹ค.

๊ฐ์ฃผ

[ํŽธ์ง‘]
  1. โ†‘ โ€œtls Extensionโ€. IRCv3 Working Group. 2012. 2024๋…„ 4์›” 6์ผ์— ํ™•์ธํ•จ.

์™ธ๋ถ€ ๋งํฌ

[ํŽธ์ง‘]