Arpa.
| سال فعال شدن | ۱ ژانویه ۱۹۸۵ |
|---|---|
| نوع دامنه سطحبالا | دامنه زیرساختی |
| وضعیت | فعال |
| ثبت | IANA |
| حمایت کننده | Internet Architecture Board |
| نیت استفاده | یک دامنه سطحبالای موقت برای تسهیل گذار از آرپانت به سامانه نام دامنه. |
| استفاده حقیقی | زیرساخت اینترنت مانند جستجوی معکوس DNS. |
| محدودیت ثبت نام | ثبت دامنه امکانپذیر نیست؛ زیردامنههای جدید بهندرت افزوده میشوند |
| ساختار | دامنههای سطح دوم برای کارکردهای گوناگون مرتبط با زیرساخت اینترنت بر اساس RFCها |
| اسناد | RFC 3172؛ RFC 9120 |
| سیاست نزاع | ندارد |
| وبسایت | اطلاعات IANA درباره .arpa |
.arpa یک دامنه سطحبالا (TLD) در سامانه نام دامنه (DNS) اینترنت است که عمدتاً برای مدیریت زیرساخت فنی شبکه بهره میگیرد. از برجستهترین کارکردهای آن، زیردامنههای in-addr.arpa و ip6.arpa هستند که فضای نامی برای جستجوی معکوس DNS آدرسهای IPv4 و IPv6 فراهم میآورند.
نام این دامنه در اصل سرنام آژانس پروژههای پژوهشی پیشرفته (ARPA) بود؛ سازمان تأمینمالی در ایالات متحده که آرپانت، پیشین اینترنت، را توسعه داد. این دامنه نخستین دامنهای بود که برای شبکه تعریف شد تا زمینه را برای یک سامانه نامگذاری سلسلهمراتبی جهت تفویض اختیار و مسئولیت فراهم کند. در ابتدا قرار بود تنها بهصورت موقت برای نامگذاری منظم رایانههای آرپانت کارکرد داشته باشد؛ اما پس از آنکه بهرهگیریهای زیرساختی از آن پذیرفته شد، حذف این دامنه از نظر عملی دشوار شد. در نتیجه، نام آن بهعنوان پسسرنام ناحیه پارامتر آدرسدهی و مسیریابی (Address and Routing Parameter Area) بازتعریف شد.
ثبت نام دامنه در arpa امکانپذیر نیست و کارگروه مهندسی اینترنت بهندرت زیردامنههای جدیدی به آن میافزاید.
هدف
[ویرایش | اشتراکگذاری]هر رایانهای که از پروتکل اینترنت بهره میگیرد با یک نشانی آیپی عددی برای شناسایی و آدرسدهی موقعیتی مشخص میشود.[۱] همچنین به هر میزبان یک نام میزبان بهیادماندنیتر نسبت داده میشود که اغلب با هدف یا مالکیت آن میزبان ارتباط دارد و در تعامل کاربر با کارکردهای شبکه — مانند اتصال به یک منبع یا دسترسی به آن — راحتتر بهره میرود. در ابتدا، نگاشت میان نامها و آدرسها فرایندی دستی و دشوار بود که از طریق جداول جستجو توزیعشده در قالب پروندههای رایانهای میان مدیران شبکه انجام میشد. سامانه نام دامنه (DNS) این ناکارآمدی را با خودکارسازی کارکرد جستجو از طریق یک سامانه نامگذاری سلسلهمراتبی بر پایه نام دامنه برطرف کرد. هنگامی که کاربر با بهرهگیری از یک نام دامنه، خدمت شبکهای را درخواست میکند، پیادهسازی پروتکل (پشته پروتکل) نام را به آدرسی ترجمه میکند که میتوان از آن برای دسترسی به میزبان راهدور بهره برد.
این کارکرد نامگذاری که اغلب «تحلیل رو به جلو» نامیده میشود، هدف اولیه دامنه سطحبالای «ARPA» بود. این دامنه نخستین دامنهای بود که در اولین سامانه نامگذاری اینترنت نوپا تعریف شد[۲] و قرار بود ظرف اولیهای برای همه میزبانهای آنزمانی آرپانت باشد. مرحله بعدی توسعه معماری نامگذاری، پیشبینی ایجاد دامنههای ویژه برای اهداف دیگر بر پایه برخی الزامات را داشت.[۲]
نگاشت معکوس آدرس IP
[ویرایش | اشتراکگذاری]در بسیاری از کاربردها، عکس نگاشت نام-به-آدرس نیز مورد نیاز است. میزبان دریافتکننده یک درخواست خدمت ممکن است به نام دامنه رایانه مبدأ نیاز داشته باشد؛ برای مثال برای شخصیسازی خدمت یا برای اهداف تأییدیه. این کارکرد که جستجوی معکوس DNS نامیده میشود، در بهرهگیریهای اصلی دامنه arpa پیادهسازی شدهاست: زیردامنههای in-addr.arpa برای پروتکل اینترنت نسخه ۴ (IPv4) و ip6.arpa برای IPv6.
کارکرد جستجو و نگاشت مفهوماً مشابهی توسط سایر زیردامنههای arpa برای انواع خاصی از دادهها فراهم میشود.
نگاشت شماره تلفن
[ویرایش | اشتراکگذاری]دامنه e164.arpa یک کارکرد جستجو فراهم میآورد که از طریق خدمت ENUM، اطلاعات مرتبط با شمارههای تلفن را بازیابی میکند. این خدمت میتواند برای بهدستآوردن نام رایانهای که قادر است درخواستهای مخابراتی مربوط به یک شماره تلفن ثبتشده را مسیریابی کند، یا برای دریافت آدرس ایمیل مشترک یک شماره تلفن خاص بهره رود.
شبکهسازی مسکونی
[ویرایش | اشتراکگذاری]نام دامنه home.arpa در می ۲۰۱۸ (اردیبهشت ۱۳۹۷) توسط کارگروه مهندسی اینترنت بهعنوان یک نام دامنه با کاربرد ویژه برای خدمات DNS غیریکتا در شبکهسازی مسکونی رزرو شد تا از بهرهگیری از دامنه سطحبالای home. که نیازمند امضاهای DNSSEC است، پرهیز شود.[۳] افزون بر این، بهرهگیری از home. موجب نشت نام دامنه به سرورهای نام ریشه اینترنت میشد. سرورهای نام معتبر برای home.arpa، سرورهای سیاهچاله AS112 هستند[۳] که از بارگذاری سرورهای ریشه توسط پرسشهای نشتیافته برای home.arpa جلوگیری میکنند.[۴]
پیشینه
[ویرایش | اشتراکگذاری]آرپانت که نامش برگرفته از آژانس پروژههای پژوهشی پیشرفته (ARPA) بود، در سال ۱۹۶۹ راهاندازی شد و نخستین پیشین اینترنت بهشمار میرود. نام این آژانس پس از گذار شبکه به شبکهسازی TCP/IP در ژانویه ۱۹۸۳ (دی ۱۳۶۱)، بهعنوان نام نخستین فضای نام رسمی شبکه پذیرفته شد.[۲] این نام بهعنوان پسوند نامگذاری برای همه میزبانهای آنزمانی آرپانت بهره میرفت. نامهای دامنهای سلسلهمراتبی برای پشتیبانی از تفویض مسئولیت و اختیار در افزودن میزبانهای آینده به شبکه در نظر گرفته شده بودند.
با توسعه رسمی چنین سامانه نامگذاری سلسلهمراتبی، این دامنه همچنین به یکی از اعضای بنیانگذار مجموعهای از نامهای دامنه برای انواع خاصی از اعضای شبکه تبدیل شد؛ یعنی com برای کاربران تجاری، org برای سازمانها، edu برای مؤسسات آموزشی، gov برای نهادهای دولتی و mil برای شبکههای نظامی ایالات متحده.[۵]
انتظار میرفت که بهرهگیری از arpa موقتی باشد و سامانههای موجود به دامنههای دیگر منتقل شوند.[۵] اما arpa همچنین آدرسهای ایمیل مرتبط با مرکز اطلاعات شبکه که سامانه نامگذاری را مدیریت میکرد، فراهم میآورد. پس از ادای هدف انتقالی، حذف این دامنه از نظر عملی دشوار بود. دامنه in-addr.arpa برای جستجوی معکوس DNS آدرسهای IP نصب شده بود.[۶]
در ابتدا، کارگروه مهندسی اینترنت در نظر داشت که پایگاههای داده زیرساختی جدید در دامنه سطحبالای int ایجاد شوند. در می ۲۰۰۰ (اردیبهشت ۱۳۷۹) این سیاست معکوس شد و تصمیم گرفته شد که دامنه سطحبالای int منحصراً برای سازمانهای بینالمللی محدود شود.[۷] Arpa برای هدف دیرپای خود حفظ شد، اما نام کامل آن به ناحیه پارامتر آدرسدهی و مسیریابی (Address and Routing Parameter Area) تغییر یافت و نام منطقه را به یک پسسرنام تبدیل کرد.[۸] ثبتنامهای خدمات زیرساختی اینترنت در .int که پیش از این تغییر سیاست انجام شده بودند، بهصورت اختیاری بهعنوان ثبتنامهای قدیمی پذیرفته شدند و ملزم به انتقال به arpa. نبودند.
در مارس ۲۰۱۰ (اسفند ۱۳۸۸)، منطقه arpa با امضاهای دیجیتال در چارچوب ضمیمههای امنیتی سامانه نام دامنه (DNSSEC) ایمن شد.[۹]
زیردامنهها
[ویرایش | اشتراکگذاری]زیردامنههای arpa از طریق فرایند درخواست توضیح (RFC) در گروههای کاری کارگروه مهندسی اینترنت ایجاد میشوند و توسط مرجع واگذاری اعداد در اینترنت (IANA) نگهداری میشوند. منطقه DNS arpa دارای زیردامنههای زیر است:[۱۰][۱۱]
| دامنه | هدف | سند معتبر (RFC) |
|---|---|---|
| 6tisch.arpa | برای IPv6 روی حالت پرش کانال زمانبندیشده از IEEE 802.15.4 | RFC 9031[۱۲] |
| as112.arpa | فروکشیدن ترافیک DNS برای تحلیل معکوس آدرس IP و موارد متفرقه (نگاه کنید به سرور سیاهچاله) | RFC 7535[۱۳] |
| e164.arpa | نگاشت شمارههای E.164 به URIهای اینترنتی | RFC 6116[۱۴] |
| eap-noob.arpa | برای روش احراز هویت خارج از باند چابک (Nimble Out-Of-Band) در چارچوب پروتکل احراز هویت توسعهپذیر | RFC 9140[۱۵] |
| home.arpa | شبکهسازی مسکونی | RFC 8375[۳] |
| in-addr.arpa | نگاشت آدرسهای IPv4 به نامهای دامنه | RFC 1035[۶] |
| ip6.arpa | نگاشت آدرسهای IPv6 به نامهای دامنه | RFC 3152[۱۶] |
| in-addr-servers.arpa | دامنههای سرورهای نام معتبر برای دامنههای جستجوی معکوس | RFC 5855[۱۷] |
| ip6-servers.arpa | ||
| ipv4only.arpa | شناسایی در دسترسبودن DNS64 و پیشوند NAT64 | RFC 7050[۱۸] |
| iris.arpa | یافتن خدمات اطلاعات ثبت اینترنت | RFC 4698[۱۹] |
| ns.arpa | دامنه برای میزبانی سرورهای نام معتبر برای دامنه .arpa | RFC 9120[۲۰] |
| resolver.arpa | دامنه برای کشف حلکنندههای DNS تعیینشده | RFC 9462[۲۱] |
| service.arpa | برای کشف خدمات مبتنی بر DNS از طریق یونیکست | RFC 9665[۲۲] |
| uri.arpa | تحلیل URIها و URNها بر اساس سامانه کشف تفویض پویا | RFC 3405[۲۳] |
| urn.arpa | ||
منابع
[ویرایش | اشتراکگذاری]- ↑ RFC 791
- 1 2 3 RFC 881
- 1 2 3 Pfister، Pierre؛ Lemon، Ted (مه ۲۰۱۸). «Special-Use Domain 'home.arpa.'». Internet Engineering Task Force.
{{cite web}}: نگهداری یادکرد:تاریخ بهطور خودکار ترجمهشده (رده) خطای یادکرد: برچسب<ref>نامعتبر؛ نام «rfc8375» چندین بار با محتوای متفاوت تعریف شده است. (صفحهٔ راهنما را مطالعه کنید.). - ↑ Maton، William F.؛ Abley، Joe (ژوئیه ۲۰۱۱). «I'm Being Attacked by PRISONER.IANA.ORG!». Internet Engineering Task Force.
{{cite web}}: نگهداری یادکرد:تاریخ بهطور خودکار ترجمهشده (رده) - 1 2 RFC 920
- 1 2 RFC 1035 خطای یادکرد: برچسب
<ref>نامعتبر؛ نام «rfc1035» چندین بار با محتوای متفاوت تعریف شده است. (صفحهٔ راهنما را مطالعه کنید.). - ↑ «IAB Statement on Infrastructure Domain and Subdomains». بایگانیشده از اصلی در ۲۷ اوت ۲۰۰۳. دریافتشده در ۱ اوت ۲۰۱۹.
{{cite web}}: از پارامتر ناشناخته|فرمت تاریخ=صرفنظر شد (کمک)نگهداری یادکرد:تاریخ بهطور خودکار ترجمهشده (رده) - ↑ RFC 3172
- ↑ «[Dnssec-deployment] Signing of the ARPA zone». بایگانیشده از اصلی در ۲۸ مارس ۲۰۱۰.
{{cite web}}: نگهداری یادکرد:تاریخ بهطور خودکار ترجمهشده (رده) - ↑ «.arpa». ICANN. بایگانیشده از اصلی در ۷ ژانویه ۲۰۰۹. دریافتشده در ۱۷ ژوئن ۲۰۲۰.
{{cite web}}: نگهداری یادکرد:تاریخ بهطور خودکار ترجمهشده (رده) - ↑ «.ARPA Zone Management». Internet Assigned Numbers Authority (IANA). بایگانیشده از روی نسخهٔ اصلی در ۹ مه ۲۰۰۸. دریافتشده در ۲ مارس ۲۰۲۳.
{{cite web}}: نگهداری یادکرد:تاریخ بهطور خودکار ترجمهشده (رده) - ↑ J. Simon; K. Pister; M. Richardson (May 2021). M. Vučinić. ed. Constrained Join Protocol (CoJP) for 6TiSCH. Internet Engineering Task Force. RFC 9031. https://tools.ietf.org/html/rfc9031. Proposed Standard.
- ↑ J. Abley; B. Dickson; W. Kumari; G. Michaelson (May 2015). AS112 Redirection Using DNAME. Internet Engineering Task Force. RFC 7535. https://tools.ietf.org/html/rfc7535. Informational.
- ↑ S. Bradner; L. Conroy; K. Fujiwara (March 2011). The E.164 to Uniform Resource Identifiers (URI) Dynamic Delegation Discovery System (DDDS) Application (ENUM). IETF. RFC 6116. https://tools.ietf.org/html/rfc6116. Proposed Standard. Obsoletes RFC 3761.
- ↑ T. Aura; M. Sethi; A. Peltonen (December 2021). Nimble Out-of-Band Authentication for EAP (EAP‑NOOB). Internet Engineering Task Force. RFC 9140. https://tools.ietf.org/html/rfc9140. Proposed Standard.
- ↑ R. Bush (August 2001). Delegation of IP6.ARPA. Network Working Group. BCP 49. RFC 3152. https://tools.ietf.org/html/rfc3152. Obsolete. Obsoleted by RFC 3596. Updates RFC 1886, 2553, 2766, 2772 and 2874
- ↑ J. Abley; T. Manderson (May 2010). Nameservers for IPv4 and IPv6 Reverse Zones. Internet Engineering Task Force. BCP 155. RFC 5855. https://tools.ietf.org/html/rfc5855. Best Current Practice 155.
- ↑ T. Savolainen; J. Korhonen; D. Wing (November 2013). Discovery of the IPv6 Prefix Used for IPv6 Address Synthesis. Internet Engineering Task Force. RFC 7050. https://tools.ietf.org/html/rfc7050. Proposed Standard. Updated by RFC 8880.
- ↑ E. Gunduz; A. Newton; S. Kerr (October 2006). IRIS: An Address Registry (areg) Type for the Internet Registry Information Service. Network Working Group. RFC 4698. https://tools.ietf.org/html/rfc4698. Proposed Standard.
- ↑ K. Davies; J. Arkko (October 2021). Nameservers for the Address and Routing Parameter Area ("arpa") Domain. Internet Engineering Task Force. RFC 9120. https://tools.ietf.org/html/rfc9120. Infomational. Updates RFC 3172.
- ↑ T. Pauly; E. Kinnear; C. A. Wood; P. McManus; T. Jensen (November 2023). Discovery of Designated Resolvers. Internet Engineering Task Force. RFC 9462. https://tools.ietf.org/html/rfc9462. Proposed Standard.
- ↑ T. Lemon; S. Cheshire (June 2025). Service Registration Protocol for DNS-Based Service Discovery. Internet Engineering Task Force. RFC 9665. https://tools.ietf.org/html/rfc9665. Proposed Standard.
- ↑ M. Mealling (October 2002). Dynamic Delegation Discovery System (DDDS) Part Five: URI.ARPA Assignment Procedures. Network Working Group. BCP 65. RFC 3405. https://tools.ietf.org/html/rfc3405. Best Current Practice 65. Updated by RFC 8958.
- مشارکتکنندگان ویکیپدیا. «.arpa». در دانشنامهٔ ویکیپدیای انگلیسی، بازبینیشده در ۲۰ مه ۲۰۲۶.
- مشارکتکنندگان ویکیپدیا. «.arpa». در دانشنامهٔ ویکیپدیای آلمانی ، بازبینیشده در ۲۰ مه ۲۰۲۶.
- مشارکتکنندگان ویکیپدیا. «.arpa». در دانشنامهٔ ویکیپدیای فرانسوی، بازبینیشده در ۲۰ مه ۲۰۲۶.